using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",([a-zA-Z].*?)(?=,[a-zA-Z]|$)";
string input = @"a=b,1,2,3,4,c=34,76,67,54,bc=78,45,h=565,64";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}