$re = '/\b(?!(?:888|999))\d+\b/';
$str = '88839182 (not valid)
99923213 (not valid)
98188823 (valid)
98939117';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);