re = /\b(?!(?:888|999))\d+\b/
str = '88839182 (not valid)
99923213 (not valid)
98188823 (valid)
98939117'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end