package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Location\s*:\s*)([a-zA-Z0-9:]*)\s*(Model\s*:\s*)([a-zA-Z0-9]*)`)
var str = `SSD Firmware Check 09/08/2020 02:49:05
==================================================================
*** Reminder: This script queries the HPE Smart Array controller through the iLO and thus will only detect drives attached to HPE Smart Array controllers. Drives in external storage enclosures where the enclosures have their own storage controller that manage their installed drives will not be detected. For these situations, further analysis will be required to confirm whether affected drives are installed. Review the iLO GUI ‘System Information -> Storage' tab ---> only drives listed on that page will be evaluated by this script. ***
Server Info:
==================================================================
SerialNumber : CZJ911084W
ServerName :
iLO HostName : ILOCZJ911084W
ServerModel : ProLiant DL360 Gen10
iLO URL :
The following discovered drives need a firmware update to Version HPD8 before PowerOnHours exceed 32,000 hours:
==================================================================
Location : 1I:1:3
Model : VK003840JWSST
PowerOnHours : 10242
SerialNumber : S48XNF0M102213
FirmwareVersion : HPD1
Failure : APPROACHING
CurrentOperatingMode : Mixed
SmartArrayModel : HPE Smart Array P816i-a SR Gen10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}