import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Location\\s*:\\s*)([a-zA-Z0-9:]*)\\s*(Model\\s*:\\s*)([a-zA-Z0-9]*)";
final String string = "SSD Firmware Check 09/08/2020 02:49:05\n"
+ "==================================================================\n"
+ "*** Reminder: This script queries the HPE Smart Array controller through the iLO and thus will only detect drives attached to HPE Smart Array controllers. Drives in external storage enclosures where the enclosures have their own storage controller that manage their installed drives will not be detected. For these situations, further analysis will be required to confirm whether affected drives are installed. Review the iLO GUI ‘System Information -> Storage' tab ---> only drives listed on that page will be evaluated by this script. ***\n"
+ "Server Info:\n"
+ "==================================================================\n\n\n"
+ "SerialNumber : CZJ911084W\n"
+ "ServerName : \n"
+ "iLO HostName : ILOCZJ911084W\n"
+ "ServerModel : ProLiant DL360 Gen10\n"
+ "iLO URL : \n\n\n\n"
+ "The following discovered drives need a firmware update to Version HPD8 before PowerOnHours exceed 32,000 hours:\n"
+ "==================================================================\n\n\n"
+ "Location : 1I:1:3\n"
+ "Model : VK003840JWSST\n"
+ "PowerOnHours : 10242\n"
+ "SerialNumber : S48XNF0M102213\n"
+ "FirmwareVersion : HPD1\n"
+ "Failure : APPROACHING\n"
+ "CurrentOperatingMode : Mixed\n"
+ "SmartArrayModel : HPE Smart Array P816i-a SR Gen10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}