$re = '/^[^-]+?(?:(?<=[\da-z])-(?=[\da-z])[^-]+?)*$/mi';
$str = 'sdh-sds-dsjh-dh
adfsfgfdfgfdg
sjkksd-
adf-adf@@!#!ccc-aaa
-sdgdsj-djbjsd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);