re = /^[^-]+?(?:(?<=[\da-z])-(?=[\da-z])[^-]+?)*$/mi
str = 'sdh-sds-dsjh-dh
adfsfgfdfgfdg
sjkksd-
adf-adf@@!#!ccc-aaa
-sdgdsj-djbjsd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end