#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td>((?:<span.*\n*){3})</td>"
Local $sString = "<tr>" & @CRLF & _
"<td><a href="/wiki/Nanga_Parbat" title="Nanga Parbat">Nanga Parbat</a></td>" & @CRLF & _
"" & @CRLF & _
"<td style="text-align: right;">8126 m<br />" & @CRLF & _
"26,660 ft</td>" & @CRLF & _
"" & @CRLF & _
"<td><span class="nowrap"><span class="flagicon"><a href="/wiki/Pakistan" title="Pakistan"><img alt="Pakistan" src="//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/23px-Flag_of_Pakistan.svg.png" width="23" height="15" class="thumbborder" srcset="//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/35px-Flag_of_Pakistan.svg.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/45px-Flag_of_Pakistan.svg.png 2x" data-file-width="900" data-file-height="600" /></a></span> <a href="/wiki/Pakistan" title="Pakistan">Pakistan</a></span></td>" & @CRLF & _
"" & @CRLF & _
"<td style="text-align: right;">3 Jul 1953</td>" & @CRLF & _
"" & @CRLF & _
"<td><span class="nowrap"><span class="flagicon"><a href="/wiki/Austria" title="Austria"><img alt="Austria" src="//upload.wikimedia.org/wikipedia/commons/thumb/4/41/Flag_of_Austria.svg/23px-Flag_of_Austria.svg.png" width="23" height="15" class="thumbborder" srcset="//upload.wikimedia.org/wikipedia/commons/thumb/4/41/Flag_of_Austria.svg/35px-Flag_of_Austria.svg.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/4/41/Flag_of_Austria.svg/45px-Flag_of_Austria.svg.png 2x" data-file-width="900" data-file-height="600" /></a></span> <a href="/wiki/Hermann_Buhl" title="Hermann Buhl">Hermann Buhl</a></span></td>" & @CRLF & _
"" & @CRLF & _
"<td style="text-align: right;">26 Feb 2016</td>" & @CRLF & _
"" & @CRLF & _
"<td><span class="nowrap"><span class="flagicon"><a href="/wiki/Italy" title="Italy"><img alt="Italy" src="//upload.wikimedia.org/wikipedia/en/thumb/0/03/Flag_of_Italy.svg/23px-Flag_of_Italy.svg.png" width="23" height="15" class="thumbborder" srcset="//upload.wikimedia.org/wikipedia/en/thumb/0/03/Flag_of_Italy.svg/35px-Flag_of_Italy.svg.png 1.5x, //upload.wikimedia.org/wikipedia/en/thumb/0/03/Flag_of_Italy.svg/45px-Flag_of_Italy.svg.png 2x" data-file-width="1500" data-file-height="1000" /></a></span> <a href="/wiki/Simone_Moro" title="Simone Moro">Simone Moro</a></span><br />" & @CRLF & _
"<span class="nowrap"><span class="flagicon"><a href="/wiki/Pakistan" title="Pakistan"><img alt="Pakistan" src="//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/23px-Flag_of_Pakistan.svg.png" width="23" height="15" class="thumbborder" srcset="//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/35px-Flag_of_Pakistan.svg.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/45px-Flag_of_Pakistan.svg.png 2x" data-file-width="900" data-file-height="600" /></a></span> <a href="/w/index.php?title=Muhammad_Ali_Sadpara&action=edit&redlink=1" class="new" title="Muhammad Ali Sadpara (page does not exist)">Muhammad Ali Sadpara</a></span><br />" & @CRLF & _
"<span class="nowrap"><span class="flagicon"><a href="/wiki/Spain" title="Spain"><img alt="Spain" src="//upload.wikimedia.org/wikipedia/en/thumb/9/9a/Flag_of_Spain.svg/23px-Flag_of_Spain.svg.png" width="23" height="15" class="thumbborder" srcset="//upload.wikimedia.org/wikipedia/en/thumb/9/9a/Flag_of_Spain.svg/35px-Flag_of_Spain.svg.png 1.5x, //upload.wikimedia.org/wikipedia/en/thumb/9/9a/Flag_of_Spain.svg/45px-Flag_of_Spain.svg.png 2x" data-file-width="750" data-file-height="500" /></a></span> <a href="/w/index.php?title=Alex_Txikon&action=edit&redlink=1" class="new" title="Alex Txikon (page does not exist)">Alex Txikon</a></span></td>" & @CRLF & _
"" & @CRLF & _
"<td style="text-align: right;">335</td>" & @CRLF & _
"<td style="text-align: right;">68</td>" & @CRLF & _
"<td style="text-align: right;">20.3%</td>" & @CRLF & _
"<td style="text-align: right;">77%</td>" & @CRLF & _
"<td style="text-align: right;">5.5%</td>" & @CRLF & _
"</tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")