# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<td>((?:<span.*\n*){3})</td>"
test_str = ("<tr>\n"
"<td><a href=\"/wiki/Nanga_Parbat\" title=\"Nanga Parbat\">Nanga Parbat</a></td>\n\n"
"<td style=\"text-align: right;\">8126 m<br />\n"
"26,660 ft</td>\n\n"
"<td><span class=\"nowrap\"><span class=\"flagicon\"><a href=\"/wiki/Pakistan\" title=\"Pakistan\"><img alt=\"Pakistan\" src=\"//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/23px-Flag_of_Pakistan.svg.png\" width=\"23\" height=\"15\" class=\"thumbborder\" srcset=\"//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/35px-Flag_of_Pakistan.svg.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/45px-Flag_of_Pakistan.svg.png 2x\" data-file-width=\"900\" data-file-height=\"600\" /></a></span> <a href=\"/wiki/Pakistan\" title=\"Pakistan\">Pakistan</a></span></td>\n\n"
"<td style=\"text-align: right;\">3 Jul 1953</td>\n\n"
"<td><span class=\"nowrap\"><span class=\"flagicon\"><a href=\"/wiki/Austria\" title=\"Austria\"><img alt=\"Austria\" src=\"//upload.wikimedia.org/wikipedia/commons/thumb/4/41/Flag_of_Austria.svg/23px-Flag_of_Austria.svg.png\" width=\"23\" height=\"15\" class=\"thumbborder\" srcset=\"//upload.wikimedia.org/wikipedia/commons/thumb/4/41/Flag_of_Austria.svg/35px-Flag_of_Austria.svg.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/4/41/Flag_of_Austria.svg/45px-Flag_of_Austria.svg.png 2x\" data-file-width=\"900\" data-file-height=\"600\" /></a></span> <a href=\"/wiki/Hermann_Buhl\" title=\"Hermann Buhl\">Hermann Buhl</a></span></td>\n\n"
"<td style=\"text-align: right;\">26 Feb 2016</td>\n\n"
"<td><span class=\"nowrap\"><span class=\"flagicon\"><a href=\"/wiki/Italy\" title=\"Italy\"><img alt=\"Italy\" src=\"//upload.wikimedia.org/wikipedia/en/thumb/0/03/Flag_of_Italy.svg/23px-Flag_of_Italy.svg.png\" width=\"23\" height=\"15\" class=\"thumbborder\" srcset=\"//upload.wikimedia.org/wikipedia/en/thumb/0/03/Flag_of_Italy.svg/35px-Flag_of_Italy.svg.png 1.5x, //upload.wikimedia.org/wikipedia/en/thumb/0/03/Flag_of_Italy.svg/45px-Flag_of_Italy.svg.png 2x\" data-file-width=\"1500\" data-file-height=\"1000\" /></a></span> <a href=\"/wiki/Simone_Moro\" title=\"Simone Moro\">Simone Moro</a></span><br />\n"
"<span class=\"nowrap\"><span class=\"flagicon\"><a href=\"/wiki/Pakistan\" title=\"Pakistan\"><img alt=\"Pakistan\" src=\"//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/23px-Flag_of_Pakistan.svg.png\" width=\"23\" height=\"15\" class=\"thumbborder\" srcset=\"//upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/35px-Flag_of_Pakistan.svg.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/3/32/Flag_of_Pakistan.svg/45px-Flag_of_Pakistan.svg.png 2x\" data-file-width=\"900\" data-file-height=\"600\" /></a></span> <a href=\"/w/index.php?title=Muhammad_Ali_Sadpara&action=edit&redlink=1\" class=\"new\" title=\"Muhammad Ali Sadpara (page does not exist)\">Muhammad Ali Sadpara</a></span><br />\n"
"<span class=\"nowrap\"><span class=\"flagicon\"><a href=\"/wiki/Spain\" title=\"Spain\"><img alt=\"Spain\" src=\"//upload.wikimedia.org/wikipedia/en/thumb/9/9a/Flag_of_Spain.svg/23px-Flag_of_Spain.svg.png\" width=\"23\" height=\"15\" class=\"thumbborder\" srcset=\"//upload.wikimedia.org/wikipedia/en/thumb/9/9a/Flag_of_Spain.svg/35px-Flag_of_Spain.svg.png 1.5x, //upload.wikimedia.org/wikipedia/en/thumb/9/9a/Flag_of_Spain.svg/45px-Flag_of_Spain.svg.png 2x\" data-file-width=\"750\" data-file-height=\"500\" /></a></span> <a href=\"/w/index.php?title=Alex_Txikon&action=edit&redlink=1\" class=\"new\" title=\"Alex Txikon (page does not exist)\">Alex Txikon</a></span></td>\n\n"
"<td style=\"text-align: right;\">335</td>\n"
"<td style=\"text-align: right;\">68</td>\n"
"<td style=\"text-align: right;\">20.3%</td>\n"
"<td style=\"text-align: right;\">77%</td>\n"
"<td style=\"text-align: right;\">5.5%</td>\n"
"</tr>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.