package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d.\d)`)
var str = `FOO_BAR_FOOBA_1_R:FOO_1.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}