$re = '/(\d.\d)/';
$str = 'FOO_BAR_FOOBA_1_R:FOO_1.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);