using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((1[6789]|[2-9][0-9])[0-9]{2}-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01]))(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^((1[6789]|[2-9][0-9])[0-9]{2}-(0[469]|11)-(0[1-9]|[12][0-9]|30))(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(((16|[248][048]|[3579][26])00)|(1[6789]|[2-9][0-9])(0[48]|[13579][26]|[2468][048]))-02-(0[1-9]|1[0-9]|2[0-9])(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(1[6789]|[2-9][0-9])[0-9]{2}-02-(0[1-9]|1[0-9]|2[0-8])(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$";
string input = @"2000-02-29 12:12:10";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}