const regex = /^((1[6789]|[2-9][0-9])[0-9]{2}-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01]))(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^((1[6789]|[2-9][0-9])[0-9]{2}-(0[469]|11)-(0[1-9]|[12][0-9]|30))(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(((16|[248][048]|[3579][26])00)|(1[6789]|[2-9][0-9])(0[48]|[13579][26]|[2468][048]))-02-(0[1-9]|1[0-9]|2[0-9])(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(1[6789]|[2-9][0-9])[0-9]{2}-02-(0[1-9]|1[0-9]|2[0-8])(\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((1[6789]|[2-9][0-9])[0-9]{2}-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01]))(\\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^((1[6789]|[2-9][0-9])[0-9]{2}-(0[469]|11)-(0[1-9]|[12][0-9]|30))(\\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(((16|[248][048]|[3579][26])00)|(1[6789]|[2-9][0-9])(0[48]|[13579][26]|[2468][048]))-02-(0[1-9]|1[0-9]|2[0-9])(\\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$|^(1[6789]|[2-9][0-9])[0-9]{2}-02-(0[1-9]|1[0-9]|2[0-8])(\\s)(([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])|(24:00:00))?$', '')
const str = `2000-02-29 12:12:10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}