package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:0814|0815|0816|0855|0856\d|0857\d|0858\d|0859\d|0[^08]\d)\d{6,9}$`)
var str = `^\d{11}$
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}