import re
regex = re.compile(r"^(?:0814|0815|0816|0855|0856\d|0857\d|0858\d|0859\d|0[^08]\d)\d{6,9}$")
test_str = ("^\\d{11}$\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")