package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`('\w+'|\d+)`)
var str = `"heres:a:func('var1', 'var2', 'var3', 2)"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}