$re = '/(\'\w+\'|\d+)/';
$str = '"heres:a:func(\'var1\', \'var2\', \'var3\', 2)"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);