$re = '/^[A-Za-z](?=.*[!*])(?=.*\d).{7,15}$/m';
$str = 'a123*foo
a!123food
a123food
a!bcdfood
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);