re = /^[A-Za-z](?=.*[!*])(?=.*\d).{7,15}$/m
str = 'a123*foo
a!123food
a123food
a!bcdfood
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end