package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*([^:]+):([^:\s]+)`)
var str = `id:pgl01130529155035239084 sub:001 dlvrd:001 submit date:1305291550 done date:1305291550 stat:DELIVRD err:0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}