// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*([^:]+):([^:\s]+)").unwrap();
let string = "id:pgl01130529155035239084 sub:001 dlvrd:001 submit date:1305291550 done date:1305291550 stat:DELIVRD err:0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}