const regex = /node_modules\/(?!@devplat\/bestie-privacy.*|whatwg-fetch).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('node_modules\\\/(?!@devplat\\\/bestie-privacy.*|whatwg-fetch).*', 'gm')
const str = `node_modules/whatwg-fetch/fetch.js
node_modules/@devplat/bestie-privacyprefences-ts-client/dist/index.js
node_modules/@babel/cli/index.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}