#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*Node\r?\n((?:(?!\*Element).*\r?\n)*)\*Element, type=S4R"
Local $sString = "**" & @CRLF & _
"*Part, name=Part-2" & @CRLF & _
"*Node" & @CRLF & _
" 1, 0.25, 0.5, 0.75" & @CRLF & _
" 2, 0.25, 0., 0.75" & @CRLF & _
" 1416, 0.200000003, 0., 0.0500000007" & @CRLF & _
"*Element, type=S4R" & @CRLF & _
" 1, 1, 21, 357, 46" & @CRLF & _
" 2, 21, 22, 358, 357" & @CRLF & _
"*Nset, nset=_PickedSet24, internal, generate" & @CRLF & _
" 1, 1416, 1" & @CRLF & _
"**"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")