using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\*Node\r?\n((?:(?!\*Element).*\r?\n)*)\*Element, type=S4R";
string input = @"**
*Part, name=Part-2
*Node
1, 0.25, 0.5, 0.75
2, 0.25, 0., 0.75
1416, 0.200000003, 0., 0.0500000007
*Element, type=S4R
1, 1, 21, 357, 46
2, 21, 22, 358, 357
*Nset, nset=_PickedSet24, internal, generate
1, 1416, 1
**";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}