const regex = /(?!<p style=".*?(margin-left:\s?(?!\k'margin')px;).*?">\* .*?<\/p>)<p style="(?P<styles>.*?)margin-left:\s?(?P<margin>[0-9]{1,3})px;?">\* (?P<listcontent>.*)<\/p>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!<p style=".*?(margin-left:\\s?(?!\\k\'margin\')px;).*?">\\* .*?<\\\/p>)<p style="(?P<styles>.*?)margin-left:\\s?(?P<margin>[0-9]{1,3})px;?">\\* (?P<listcontent>.*)<\\\/p>', 'gm')
const str = `<p style="color: blue">Some text</p>
<p style="color:blue; margin-left: 10px">* Item 1</p> (Should be matched)
<p style="margin-left: 10px">* Item 2</p>
<p style="margin-left: 20px">* Sub Item 1a</p> (Should be matched)
<p style="margin-left: 20px">* Sub Item 2a</p>
<p style="margin-left: 10px">* Item 3</p>
<p style="margin-left: 20px">* Sub Item 1b</p> (Should be matched)
<p style="margin-left: 20px">* Sub Item 2b</p>
<p style="margin-left: 30px">* Sub Item 1c</p>
<p>Some text</p>
<p style="color:blue; margin-left: 10px">* Item 1</p> (Should be matched)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}