$re = '/(?!<p style=".*?(margin-left:\s?(?!\k\'margin\')px;).*?">\* .*?<\/p>)<p style="(?P<styles>.*?)margin-left:\s?(?P<margin>[0-9]{1,3})px;?">\* (?P<listcontent>.*)<\/p>/m';
$str = '<p style="color: blue">Some text</p>
<p style="color:blue; margin-left: 10px">* Item 1</p> (Should be matched)
<p style="margin-left: 10px">* Item 2</p>
<p style="margin-left: 20px">* Sub Item 1a</p> (Should be matched)
<p style="margin-left: 20px">* Sub Item 2a</p>
<p style="margin-left: 10px">* Item 3</p>
<p style="margin-left: 20px">* Sub Item 1b</p> (Should be matched)
<p style="margin-left: 20px">* Sub Item 2b</p>
<p style="margin-left: 30px">* Sub Item 1c</p>
<p>Some text</p>
<p style="color:blue; margin-left: 10px">* Item 1</p> (Should be matched)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);