import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "maxiobe namespaces";
final String string = "<?php\n"
+ "require_once __DIR__ . '/src/Models/Device.php';\n"
+ "require_once __DIR__ . '/src/Models/Smartphone.php';\n\n"
+ "use App\\Models\\Device;\n"
+ "use App\\Models\\Smartphone;\n\n"
+ "$myDevice = new Device();\n"
+ "$myDevice->turnOn();\n"
+ "$myDevice->turnOff();\n\n"
+ "echo \"<hr>\";\n\n"
+ "$myPhone = new Smartphone();\n"
+ "$myPhone->turnOn();\n"
+ "$myPhone->takePhoto();\n"
+ "$myPhone->turnOff();\n\n\n\n\n"
+ "devices.php:\n\n"
+ "<?php\n"
+ "namespace App\\Models;\n\n"
+ "class Device {\n"
+ " public function turnOn(): void {\n"
+ " echo \"Gerät eingeschaltet.<br>\";\n"
+ " }\n\n"
+ " public function turnOff(): void {\n"
+ " echo \"Gerät ausgeschaltet.<br>\";\n"
+ " }\n"
+ "}\n\n\n\n"
+ "Smartphone.php:\n\n"
+ "<?php\n"
+ "namespace App\\Models;\n\n"
+ "class Smartphone extends Device {\n"
+ " public function takePhoto(): void {\n"
+ " echo \"Foto gemacht! 📸<br>\";\n"
+ " }\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}