import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:https?:\\/\\/)?(?:www\\.)?)?(youtube(?:-nocookie)?\\.com|youtu\\.be)\\/.*?(?:embed|e|v|watch\\?.*?v=)?\\/?([a-z0-9]+)";
final String string = "Using above method following URL , didnt work\n\n"
+ "http://www.youtube.com/e/dQw4w9WgXcQ\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
+ "Other links working fine\n\n"
+ "http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0 \n"
+ "http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg\n"
+ "http://youtu.be/0zM3nApSvMg\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://youtu.be/dQw4w9WgXcQ\n"
+ "http://www.youtube.com/embed/dQw4w9WgXcQ\n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ\n"
+ "http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}