# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:https?:\/\/)?(?:www\.)?)?(youtube(?:-nocookie)?\.com|youtu\.be)\/.*?(?:embed|e|v|watch\?.*?v=)?\/?([a-z0-9]+)"
test_str = ("Using above method following URL , didnt work\n\n"
"http://www.youtube.com/e/dQw4w9WgXcQ\n"
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
"Other links working fine\n\n"
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0 \n"
"http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg\n"
"http://youtu.be/0zM3nApSvMg\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"http://youtu.be/dQw4w9WgXcQ\n"
"http://www.youtube.com/embed/dQw4w9WgXcQ\n"
"http://www.youtube.com/v/dQw4w9WgXcQ\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ\n"
"http://www.youtube-nocookie.com/v/6L3ZvIMwZFM?version=3&hl=en_US&rel=0")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.