#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?P<date>(?P<day>3[0-1]|[0-2]?[\d])(?P<separator>\/|\-|\.)(?P<month>1[0-2]|[0-1]?[\d])\3(?P<year>[\d]{4}|[\d]{2}))"
Local $sString = "este es el 22/11/2015 o el 8/2/1982 o el 9-5-2012 o tal vez el 10.10.15 mas que 9-5-12 tdo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")