import re
regex = re.compile(r"\b(?P<date>(?P<day>3[0-1]|[0-2]?[\d])(?P<separator>\/|\-|\.)(?P<month>1[0-2]|[0-1]?[\d])\3(?P<year>[\d]{4}|[\d]{2}))")
test_str = "este es el 22/11/2015 o el 8/2/1982 o el 9-5-2012 o tal vez el 10.10.15 mas que 9-5-12 tdo"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")