using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2}([\/.-])\d{2}\1\d{4}";
string input = @"On the 03/09/2015 I am swiming in a pool, that was build on the 27-03-1994 02.02.2200";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}