re = /\d{2}([\/.-])\d{2}\1\d{4}/
str = 'On the 03/09/2015 I am swiming in a pool, that was build on the 27-03-1994 02.02.2200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end