using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s].+[^\s])";
string input = @"G-ITDep-Location-RWXD
G-R-ITHR-666-42-All-RWXD
G-R-ITHR-666-42-All-EndUsers
SP-P-TKDep-ISIS-Member
Domain Users";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}