$re = '/([^\s].+[^\s])/m';
$str = 'G-ITDep-Location-RWXD
G-R-ITHR-666-42-All-RWXD
G-R-ITHR-666-42-All-EndUsers
SP-P-TKDep-ISIS-Member
Domain Users';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);