package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9\d{2,}|[3-9]\d|2[5-9])000$`)
var str = `10000
25000
25100
30
30000
25000100
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}