const regex = /[,+]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[,+]', 'g')
const str = `{1,1,0,0,0,4,0,0,0,0,20,4099,4241,706,706,714,714,817,824,824,824,2,2,2,2,1,1,1,1},`;
const subst = `{`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);