package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([01]?\d?\d|2[0-4]\d|25[0-5])\.){2}([01]?\d?\d|2[0-4]\d|25[0-5])$`)
var str = `255.145.246`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}