re = /^(([01]?\d?\d|2[0-4]\d|25[0-5])\.){2}([01]?\d?\d|2[0-4]\d|25[0-5])$/
str = '255.145.246'
# Print the match result
str.match(re) do |match|
puts match.to_s
end