$re = '/^([1-2]\d|3[01]|\d)\./s';
$str = '4.9.2017';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;