import re
regex = re.compile(r"^([1-2]\d|3[01]|\d)\.", flags=re.DOTALL)
test_str = "4.9.2017"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)