package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^:]*)(?::([^:\n]+))?$`)
var str = `123.45.34.5:8080
123.45.34.5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}