$re = '/^([^:]*)(?::([^:\n]+))?$/m';
$str = '123.45.34.5:8080
123.45.34.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);