# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?(<\/?\w+).*?(\/?>).*?"
test_str = ("<!doctype html>\n"
"<html>\n"
"<head>\n"
"<title>Example Domain</title>\n\n"
"<meta charset=\"utf-8\" />\n"
"<meta http-equiv=\"Content-type\" content=\"text/html; charset=utf-8\" />\n"
"<meta name=\"viewport\" content=\"width=device-width, initial-scale=1\" />\n"
"<style type=\"text/css\">\n"
"body {\n"
" background-color: #f0f0f2;\n"
" margin: 0;\n"
" padding: 0;\n"
" font-family: \"Open Sans\", \"Helvetica Neue\", Helvetica, Arial, sans-serif;\n\n"
"}\n"
"div {\n"
" width: 600px;\n"
" margin: 5em auto;\n"
" padding: 50px;\n"
" background-color: #fff;\n"
" border-radius: 1em;\n"
"}\n"
"a:link, a:visited {\n"
" color: #38488f;\n"
" text-decoration: none;\n"
"}\n"
"@media (max-width: 700px) {\n"
" body {\n"
" background-color: #fff;\n"
" }\n"
" div {\n"
" width: auto;\n"
" margin: 0 auto;\n"
" border-radius: 0;\n"
" padding: 1em;\n"
" }\n"
"}\n"
"</style> \n"
"</head>\n\n"
"<body>\n"
"<div>")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.