package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<@!?(\d+)>`)
var str = `<@130846699953324032>
<@!802537629148905502>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}