$re = '/<@!?(\d+)>/';
$str = '<@130846699953324032>
<@!802537629148905502>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);