#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(?<given_name>(?:[^.,!?;:\s]+\s)*?(?:[^.,!?;:\s]+))(?:\s(?:(?<middle_initial>[^.,!?;:\s])(?:\.\s|\.)?)??(?<family_name>(?:(?:(?:(?:a|ab|af|ap|abu|aït|al|ālam|at|ath|aust|austre|bar|bath|bat|ben|bin|ibn|bet|bint|da|das|de la|degli|del|dele|della|der|di|dos|du|e|el|fetch|vetch|fitz|i|ka|kil|gil|la|le|lille|lu|m'|mac|mc|mck|mhic|mic|mala|mellom|myljom|na|ณ|ned|nedre|neder|ngā|nic|ní|nin|nord|norr|ny|o|ó|ua|uí|opp|upp|öfver|ost|öst|öster|øst|østre|över|øvste|øvre|øver|öz|pour|putra|putera|putri|puteri|setia|setya|stor|söder|sør|sønder|syd|søndre|syndre|søre|te|ter|ter|tre|van|van de|van den|van der|van het|van 't|väst|väster|verch|erch|vest|vestre|vesle|vetle|von|war|zu|von und zu)\s)?[^.,!?;:\s]+)-)?(?:(?:a|ab|af|ap|abu|aït|al|ālam|at|ath|aust|austre|bar|bath|bat|ben|bin|ibn|bet|bint|da|das|de la|degli|del|dele|della|der|di|dos|du|e|el|fetch|vetch|fitz|i|ka|kil|gil|la|le|lille|lu|m'|mac|mc|mck|mhic|mic|mala|mellom|myljom|na|ณ|ned|nedre|neder|ngā|nic|ní|nin|nord|norr|ny|o|ó|ua|uí|opp|upp|öfver|ost|öst|öster|øst|østre|över|øvste|øvre|øver|öz|pour|putra|putera|putri|puteri|setia|setya|stor|söder|sør|sønder|syd|søndre|syndre|søre|te|ter|ter|tre|van|van de|van den|van der|van het|van 't|väst|väster|verch|erch|vest|vestre|vesle|vetle|von|war|zu|von und zu)\s)?[^.,!?;:\s]+)??(?:,?\s(?<suffix>Sr\.?|Snr|Jr\.?|Jnr|[IVX]+))?)?$"
Local $sString = "John Doe" & @CRLF & _
"Mary Jane Smith" & @CRLF & _
"Jean-Luc van der Berg Sr." & @CRLF & _
"Maria de la Cruz" & @CRLF & _
"Mohamed bin Ahmed al-Farsi" & @CRLF & _
"Anna-Nicole Johnson Jr." & @CRLF & _
"Carlos Alberto dos Santos" & @CRLF & _
"Sophie von und zu Rhein" & @CRLF & _
"Li Na" & @CRLF & _
"O'Connor Fitzpatrick III" & @CRLF & _
"Yusuf ibn Abdullah" & @CRLF & _
"Emma-Louise O'Reilly" & @CRLF & _
"Juan Carlos de la Torre" & @CRLF & _
"Fatima bint Mohammed" & @CRLF & _
"Hans-Christian Andersen" & @CRLF & _
"Elena di Matteo" & @CRLF & _
"Abdul-Rahman al-Hashimi" & @CRLF & _
"Isabella della Rovere" & @CRLF & _
"Jean-Pierre Dupont Jr" & @CRLF & _
"Sara van den Berg" & @CRLF & _
"John Q. Public"
Local $sSubst = "First_Name: "$1"\nMiddle_Initial: "$2"\nLastName: "$3"\nSuffix: "$4"\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)