import re
regex = re.compile(r"^(?<given_name>(?:[^.,!?;:\s]+\s)*?(?:[^.,!?;:\s]+))(?:\s(?:(?<middle_initial>[^.,!?;:\s])(?:\.\s|\.)?)??(?<family_name>(?:(?:(?:(?:a|ab|af|ap|abu|aït|al|ālam|at|ath|aust|austre|bar|bath|bat|ben|bin|ibn|bet|bint|da|das|de la|degli|del|dele|della|der|di|dos|du|e|el|fetch|vetch|fitz|i|ka|kil|gil|la|le|lille|lu|m'|mac|mc|mck|mhic|mic|mala|mellom|myljom|na|ณ|ned|nedre|neder|ngā|nic|ní|nin|nord|norr|ny|o|ó|ua|uí|opp|upp|öfver|ost|öst|öster|øst|østre|över|øvste|øvre|øver|öz|pour|putra|putera|putri|puteri|setia|setya|stor|söder|sør|sønder|syd|søndre|syndre|søre|te|ter|ter|tre|van|van de|van den|van der|van het|van 't|väst|väster|verch|erch|vest|vestre|vesle|vetle|von|war|zu|von und zu)\s)?[^.,!?;:\s]+)-)?(?:(?:a|ab|af|ap|abu|aït|al|ālam|at|ath|aust|austre|bar|bath|bat|ben|bin|ibn|bet|bint|da|das|de la|degli|del|dele|della|der|di|dos|du|e|el|fetch|vetch|fitz|i|ka|kil|gil|la|le|lille|lu|m'|mac|mc|mck|mhic|mic|mala|mellom|myljom|na|ณ|ned|nedre|neder|ngā|nic|ní|nin|nord|norr|ny|o|ó|ua|uí|opp|upp|öfver|ost|öst|öster|øst|østre|över|øvste|øvre|øver|öz|pour|putra|putera|putri|puteri|setia|setya|stor|söder|sør|sønder|syd|søndre|syndre|søre|te|ter|ter|tre|van|van de|van den|van der|van het|van 't|väst|väster|verch|erch|vest|vestre|vesle|vetle|von|war|zu|von und zu)\s)?[^.,!?;:\s]+)??(?:,?\s(?<suffix>Sr\.?|Snr|Jr\.?|Jnr|[IVX]+))?)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("John Doe\n"
"Mary Jane Smith\n"
"Jean-Luc van der Berg Sr.\n"
"Maria de la Cruz\n"
"Mohamed bin Ahmed al-Farsi\n"
"Anna-Nicole Johnson Jr.\n"
"Carlos Alberto dos Santos\n"
"Sophie von und zu Rhein\n"
"Li Na\n"
"O'Connor Fitzpatrick III\n"
"Yusuf ibn Abdullah\n"
"Emma-Louise O'Reilly\n"
"Juan Carlos de la Torre\n"
"Fatima bint Mohammed\n"
"Hans-Christian Andersen\n"
"Elena di Matteo\n"
"Abdul-Rahman al-Hashimi\n"
"Isabella della Rovere\n"
"Jean-Pierre Dupont Jr\n"
"Sara van den Berg\n"
"John Q. Public")
subst = "First_Name: \"$1\"\\nMiddle_Initial: \"$2\"\\nLastName: \"$3\"\\nSuffix: \"$4\"\\n"
result = regex.sub(subst, test_str)
if result:
print(result)