package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^\]]*\]|(-)`)
var str = `[Wsg-Fs]-A-A-A-Cgbs-Sg7-[Wwg+s-Fs]-A-A-Afk-Cgbs-Sg7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}