re = /\[[^\]]*\]|(-)/
str = '[Wsg-Fs]-A-A-A-Cgbs-Sg7-[Wwg+s-Fs]-A-A-Afk-Cgbs-Sg7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end